Extreme GPU Bruteforcer

[Russian]
Extreme GPU Bruteforcer

IMPORTANT! You may use this software for the recovery of your own forgotten passwords only!

Program Description
INI File Parameters
FAQ
Program Description

The software recovers passwords from hashes of different types using GPU. That allows reaching outstanding attack speeds:

Algorithm | Average Speed (when attacking one hash on NVIDIA GTX650Ti)
MD5 | 680 million p/s
MD4 | 770 million p/s
LM | 30 million p/s
NTLM | 690 million p/s
SHA-1 | 205 million p/s
MySQL | 1230 million p/s
MySQL5 | 115 million p/s
SHA-256 | 80 million p/s
SHA-384 | 35 million p/s
SHA-512 | 35 million p/s
RAdmin v2.x | 390 million p/s
GOST R 34.11-94 | 1,5 million p/s
md5(md5($pass)) | 150 million p/s
sha1($salt.sha1($pass)) | 65 million p/s
substr(md5($pass),8,16) | 635 million p/s
substr(md5($pass),16,16) | 630 million p/s
md5(sha1($pass)) | 85 million p/s
sha1(md5($pass)) | 100 million p/s
sha256(md5($pass)) | 55 million p/s
Domain Cached Credentials | 420 million p/s
MD5(APR) | 0,65 million p/s
MD5(Unix) | 0,65 million p/s
DES(Unix) | 0,8 million p/s
MD5(phpBB3) | 0,35 million p/s
MD5(Wordpress) | 0,1 million p/s
md5($pass.$salt) | 750 million p/s
md5($salt.$pass) | 725 million p/s
md5(md5($pass).$salt) | 145 million p/s
md5(md5($salt).$pass) | 660 million p/s
md5($salt.md5($pass)) | 140 million p/s
md5($salt.$pass.$salt) | 700 million p/s
md5(md5($pass).md5($salt)) | 125 million p/s
md5(md5($salt).md5($pass)) | 125 million p/s
md5(1.$pass.$salt) | 720 million p/s
md5($username.0.$pass) | 720 million p/s
sha1($pass.$salt) | 210 million p/s
sha1($salt.$pass) | 210 million p/s
sha1(strtolower($username).$pass) | 210 million p/s
sha256($pass.$salt) | 80 million p/s
sha256($salt.$pass) | 80 million p/s
sha512($pass.$salt) | 30 million p/s
sha512($salt.$pass) | 30 million p/s
md5($unicodepass) | 640 million p/s
SAPB | 90 million p/s
sha1(sha1($salt.$pass)) | 70 million p/s
SSHA-1 | 210 million p/s
substr(md5($pass),12,20) | 620 million p/s
md5($username.LF.$pass) | 700 million p/s
sha1(sha1($pass)) | 65 million p/s
SHA-1(Oracle) | 200 million p/s
MSSQL(2005) | 200 million p/s
sha256(sha1($pass)) | 45 million p/s
md5($unicodepass.$salt) | 720 million p/s
md5($salt.$unicodepass) | 590 million p/s
md5(md5($unicodepass).$salt) | 140 million p/s
sha1($unicodepass) | 195 million p/s
sha1($unicodepass.$salt) | 200 million p/s
sha1($salt.$unicodepass) | 190 million p/s
sha384($pass.$salt) | 30 million p/s
sha384($salt.$pass) | 30 million p/s
Keccak-224 | 1.8 million p/s
Keccak-256 | 1.8 million p/s
Keccak-384 | 1.8 million p/s
Keccak-512 | 1.8 million p/s
sha256($unicodepass) | 77 million p/s
substr(md5($pass),0,16) | 680 million p/s
substr(sha1($pass),0,32) | 200 million p/s

To run the program, pass the following mandatory command-line parameters to it:

1. Algorithm
2. Name of the INI file with attack settings
3. Name of the text file with hashes

Examples of running the program:

EGB.exe "MD5" MD5.ini Hashes.txt
EGB.exe "MySQL" D.ini Hashes.txt
etc.

To obtain the information about GPU, run the program as follows:

EGB.exe /getdeviceinfo
INI File Parameters

[BruteForceAttack]

In this section, you can describe up to 512 attacks, which would run in series, one after another. The settings of each attack are defined in the parameters 1, 2 ... 512, in the following format:
Attack Number=Character set,Minimum password length,Maximum password length

Example settings:
[BruteForceAttack]
1=?d,1,12
2=?l?u?d,4,6
3=0123456789abcdef,2,8

Note: All attacks support the following standard character sets:
?d – 0123456789
?l – abcdefghijklmnopqrstuvwxyz
?u – ABCDEFGHIJKLMNOPQRSTUVWXYZ
?s – !@#$%^&*()`~-_=+\|[]{};:'",.<>/?

[MaskAttack]

In this section, you can describe up to 512 mask attacks, which would also run in series, one after another. Each attack is defined in the parameters 1, 2 ... 512, in the following format:
Attack Number=Mask,Minimum password length,Maximum password length

Example settings:
[MaskAttack]
1=Admin?d?d?d?d?d?d,6,11
2=?u?l?l?l?l?l?l?l,1,8
3=?u?umaster?d?d,10,10

[DictionaryAttack]

In this section, you can define up to 512 dictionaries, which would be used for running a simple dictionary attack; for example:
[DictionaryAttack]
1=D:\1.dic
2=D:\2.dic
3=D:\3.dic

[HybridAttack]

In this section, you can define up to 512 hybrid attack rules, which are to be defined as masks (similarly to the mask attack); a dictionary password should be denoted by a special symbol @. This attack supports only one dictionary, which is to be defined in the "Dictionary" parameter in the same section; for example:
[HybridAttack]
Dictionary=D:\InsidePro (Mini).dic
1=@?d?d?d?d
2=?u?u@
3=admin@

Examples of rules for this attack:
@?d?d?d?d – 4 trailing digits would be added to a dictionary password.
?u?u@ – two leading characters from the "A...Z" range would be added to a dictionary password.
admin@ – a leading "admin" string would be added to a dictionary password.

This attack also supports complex masks, of types ?u@?l?l, ilove@?d?d?d?d or Summer?u?d@?s (i.e. masks can be defined on both the left and on the right side of the dictionary password). Moreover – the program supports masks of any length; for example, @?d?d?d?d?d?d or ?u@?l?l?d?d; the only limitation is that the number of password combinations in one rule can not exceed StreamProcessors * StreamProcessors * PasswordsPerThread.

[Settings]

In this section, you can specify the application's general settings.

AttackMode – select the desired attack; available values: 1 (brute-force attack), 2 (mask attack), 3 (dictionary attack) or 4 (hybrid attack). In this parameter, you can also specify the initial rule, which the attack is to start with; for example:
AttackMode=2,4 – launch a mask attack starting with the 4-th mask.
AttackMode=3,10 – launch a dictionary attack starting with the 10-th dictionary.
AttackMode=4,64 – launch a hybrid attack starting with the 64-th rule.

LastPassword – this parameter stores last processed password. Therefore, when the program is launched again, the attack will resume from that password. Thus, in order to start the attack all over, you will need to drop the value in this parameter. Note: If you don't want to have last processed password stored in the INI file set the Read-only attribute on that INI file.

CurrentDevice – this parameter allows you to choose, on which of the available GPU to launch the attack. This allows to manage the load on the GPU more effectively and run simultaneous attack with different settings on different GPU. The default value is 1. To use multiple GPU simultaneously, list their numbers separating them with a comma, for example:
CurrentDevice=1,2
CurrentDevice=1,4
CurrentDevice=2,3,4
CurrentDevice=1,2,5,6,7,8
In this mode, you can set individual StreamProcessors and PasswordsPerThread values for each GPU, also listing them via a comma, like this:
CurrentDevice=1,2
StreamProcessors=112,96
PasswordsPerThread=6000,2000
or
CurrentDevice=1,2,3,4
StreamProcessors=128,128,128,64
PasswordsPerThread=3000,3000,3000,100

StreamProcessors – number of stream processors; the default value is 128.

PasswordsPerThread – number of passwords to be processed in one thread; by default - 3000 passwords for unsalted hashes, and 100 passwords for salted ones.

SaltInHexFormat – determines salt (or user name) format:
"0" (default) – plain text format
"1" – hexadecimal format

RemoveCrackedHashes – this parameter allows removing recovered hashes from the original text file. On the "1" value, the recovered hashes will be deleted; on the "0" value (default) – the hashes will be preserved.

OutputFileFormat – this parameter defines the format, in which found passwords are to be appended to EGB.out file. The following values are supported:
"0" – writes nothing to file
"1" (default value) – hash:password
"2" – password
"3" – hash:[color=blue]password[/color]
"4" – hash:salt:password

ShowFoundPasswords – defines whether or not to display found passwords on screen. When set to '1' (default), passwords are displayed, when set to '0' - they aren't.

CustomCharacterSet1 ... CustomCharacterSetZ – custom character sets that you can use in a mask or hybrid attack, marking them as character sets ?1 ... ?9 and ?A ... ?Z.
FAQ

Q1: What are the system requirements that your program lays down?
A: The main requirement is that your video card must support the CUDA technology (you can find the list of such video cards here). Other than that, you must have the latest drivers for it installed on your video card. It is also necessary that the video card supports the sm_11 and higher architecture.

Q2: My video card has an ATI GPU. Will your program work with it?
A: No, it will not, since the CUDA (Compute Unified Device Architecture) technology is only supported by GPU manufactured by NVIDIA.

Q3: When I launch the program, it brings up a DOS prompt window, which disappears the very next moment. How am I supposed to work with the program?
A: For the convenient operation, use a file manager that runs in the DOS mode; e.g., FAR Manager.

Q4: The program pops the "CUDA Error..." message on startup. How can it be fixed?
A: First of all, make sure that your video card supports the CUDA technology, and you have got the latest video card drivers installed. If these requirements have been observed, and the error persists, please send the following information to our Technical Support Service for the analysis: error message, and exact model of your video card.

Q5: My computer hangs or shows the "Blue Screen of Death" (BSOD) when the program is launched. How can this be fixed?
A: That can take place when your GPU is over-clocked; therefore, it is recommended that you restore the original values of the GPU and memory clock. Also, make sure that your video card receives reliable and quality cooling, as the program employs the full power of your GPU and, consequently, in this operating mode its temperature goes up. Also, running under the full load, the video card consumes a great amount of electricity, and your power supply may fail to meet such power demands.

Q6: I managed to launch the program; now, how can I halt it?
A: Press the Ctrl+C or Ctrl+Break shortcuts on the keyboard.

Q7: I launched the program, and now my computer runs really slow. How can this be fixed?
A: By default, the program is configured to run in the extreme operating mode, where the computer is loaded with only one job – recovering passwords at the highest speed possible. Obviously, that leads to slowing down the operating speed of the rest of applications. To decrease the load on your computer, decrease the value in the PasswordsPerThread parameter in the INI file.

Q8: Does the program recover passwords that contain national characters; for example, Cyrillic?
A: Yes, it does; for that purpose, in the CharacterSet parameter of your INI file enter the required character set.

Q9: When I launch an attack to recover salted hashes, my computer freezes or displays BSOD. Why?
A: Since the speed of processing salted hashes decreases proportionally to their number, with a great number of hashes it is necessary to decrease the value of PasswordsPerThread (and of StreamProcessors when that's necessary). Otherwise, the total number of threads in a GPU, multiplied by the number of hashes in each thread, with a low attack speed will lead to the point where the GPU will become overloaded with calculations and will take too long to respond to the driver's queries.

Q10: Now, how do I determine whether or not GPU is overloaded?
A: In the normal state, EGB refreshes the attack speed indicator 2 times per second; therefore, if the refresh rate on your screen is noticeably lower, your GPU is overloaded, and you need to lower the values of PasswordsPerThread and StreamProcessors.

Q11: When I launch an attack with a long mask, the status string (which shows the attack speed and current password) sometimes doesn't fit the size of the console window. How could that be fixed?
A: To ensure the proper appearance of long passwords on the application's status bar, expand the width of the console window through its properties (that feature is available beginning with Windows 2000/XP) – for example, instead of the default 80 characters, you can set 100 or even more (if the resolution of the screen and current console font allow).

Q12: Are you planning to add the support for OpenCL to your software?
A: Unlikely we are going to do that in the near future, although it is possible some time later.

Q13: Occasionally, some time after the program starts, it returns an error: "CUDA Error...". What could cause it?
A: Most often this happens because the video card keeps being actively used; that could be a running screensaver, playing video, etc. Obviously, to ensure a stable operation of EGB for long hours (or even days), you need to disable such extraneous applications when attacking hashes.

Copyright © 2008-2014 InsidePro Software


Extreme GPU Bruteforcer

[English]
Extreme GPU Bruteforcer

Внимание! Данная программа может использоваться исключительно для восстановления своих собственных забытых паролей!

Описание программы
Параметры INI-файла
FAQ
Описание программы

Программа предназначена для восстановления паролей к хэшам различных типов c использованием видеопроцессора (GPU), что позволяет добиться огромных скоростей перебора паролей:

Алгоритм | Средняя скорость (при атаке на один хэш на NVIDIA GTX650Ti)
MD5 | 680 миллионов п/с
MD4 | 770 миллионов п/с
LM | 30 миллионов п/с
NTLM | 690 миллионов п/с
SHA-1 | 205 миллионов п/с
MySQL | 1230 миллионов п/с
MySQL5 | 115 миллионов п/с
SHA-256 | 80 миллионов п/с
SHA-384 | 35 миллионов п/с
SHA-512 | 35 миллионов п/с
RAdmin v2.x | 390 миллионов п/с
GOST R 34.11-94 | 1,5 миллиона п/с
md5(md5($pass)) | 150 миллионов п/с
sha1($salt.sha1($pass)) | 65 миллионов п/с
substr(md5($pass),8,16) | 635 миллионов п/с
substr(md5($pass),16,16) | 630 миллионов п/с
md5(sha1($pass)) | 85 миллионов п/с
sha1(md5($pass)) | 100 миллионов п/с
sha256(md5($pass)) | 55 миллионов п/с
Domain Cached Credentials | 420 миллионов п/с
MD5(APR) | 0,65 миллиона п/с
MD5(Unix) | 0,65 миллиона п/с
DES(Unix) | 0,8 миллиона п/с
MD5(phpBB3) | 0,35 миллиона п/с
MD5(Wordpress) | 0,1 миллиона п/с
md5($pass.$salt) | 750 миллионов п/с
md5($salt.$pass) | 725 миллионов п/с
md5(md5($pass).$salt) | 145 миллионов п/с
md5(md5($salt).$pass) | 660 миллионов п/с
md5($salt.md5($pass)) | 140 миллионов п/с
md5($salt.$pass.$salt) | 700 миллионов п/с
md5(md5($pass).md5($salt)) | 125 миллионов п/с
md5(md5($salt).md5($pass)) | 125 миллионов п/с
md5(1.$pass.$salt) | 720 миллионов п/с
md5($username.0.$pass) | 720 миллионов п/с
sha1($pass.$salt) | 210 миллионов п/с
sha1($salt.$pass) | 210 миллионов п/с
sha1(strtolower($username).$pass) | 210 миллионов п/с
sha256($pass.$salt) | 80 миллионов п/с
sha256($salt.$pass) | 80 миллионов п/с
sha512($pass.$salt) | 30 миллионов п/с
sha512($salt.$pass) | 30 миллионов п/с
md5($unicodepass) | 640 миллионов п/с
SAPB | 90 миллионов п/с
sha1(sha1($salt.$pass)) | 70 миллионов п/с
SSHA-1 | 210 миллионов п/с
substr(md5($pass),12,20) | 620 миллионов п/с
md5($username.LF.$pass) | 700 миллионов п/с
sha1(sha1($pass)) | 65 миллионов п/с
SHA-1(Oracle) | 200 миллионов п/с
MSSQL(2005) | 200 миллионов п/с
sha256(sha1($pass)) | 45 миллионов п/с
md5($unicodepass.$salt) | 720 миллионов п/с
md5($salt.$unicodepass) | 590 миллионов п/с
md5(md5($unicodepass).$salt) | 140 миллионов п/с
sha1($unicodepass) | 195 миллионов п/с
sha1($unicodepass.$salt) | 200 миллионов п/с
sha1($salt.$unicodepass) | 190 миллионов п/с
sha384($pass.$salt) | 30 миллионов п/с
sha384($salt.$pass) | 30 миллионов п/с
Keccak-224 | 1.8 миллиона п/с
Keccak-256 | 1.8 миллиона п/с
Keccak-384 | 1.8 миллиона п/с
Keccak-512 | 1.8 миллиона п/с
sha256($unicodepass) | 77 миллионов п/с
substr(md5($pass),0,16) | 680 миллионов п/с
substr(sha1($pass),0,32) | 200 миллионов п/с

Для работы программы ей нужно передать следующие обязательные параметры командной строки:

1. Название алгоритма
2. Имя файла с настройками атаки
3. Имя текстового файла с хэшами

Примеры запуска программы:

EGB.exe "MD5" MD5.ini Hashes.txt
EGB.exe "MySQL" D.ini Hashes.txt
и т.д.

Для получения информации о GPU необходимо запустить программу следующим образом:

EGB.exe /getdeviceinfo
Параметры INI-файла

[BruteForceAttack]

В этой секции можно описать до 512 атак полным перебором, которые будут выполняться последовательно друг за другом. Настройки каждой атаки задаются в параметрах 1, 2 ... 512 в следующем формате:
Номер атаки=Набор символов,Минимальная длина паролей,Максимальная длина паролей

Пример настроек:
[BruteForceAttack]
1=?d,1,12
2=?l?u?d,4,6
3=0123456789abcdef,2,8

Примечание: во всех видах атак поддерживаются следующие стандартные наборы символов:
?d – 0123456789
?l – abcdefghijklmnopqrstuvwxyz
?u – ABCDEFGHIJKLMNOPQRSTUVWXYZ
?s – !@#$%^&*()`~-_=+\|[]{};:'",.<>/?

[MaskAttack]

В этой секции можно описать до 512 атак по маске, которые будут выполняться последовательно друг за другом. Каждая маска задается в параметрах 1, 2 ... 512 в следующем формате:
Номер атаки=Маска,Минимальная длина паролей,Максимальная длина паролей

Пример настроек:
[MaskAttack]
1=Admin?d?d?d?d?d?d,6,11
2=?u?l?l?l?l?l?l?l,1,8
3=?u?umaster?d?d,10,10

[DictionaryAttack]

В этой секции можно задать до 512 словарей, по которым будет выполняться простая атака по словарям, например:
[DictionaryAttack]
1=D:\1.dic
2=D:\2.dic
3=D:\3.dic

[HybridAttack]

В этой секции можно задать до 512 правил гибридной атаки, которые задаются в виде масок (по аналогии с атакой по маске), при этом пароль из словаря обозначается специальным символом @. В этой атаке поддерживается работа только с одним словарем и этот словарь задается в параметре "Dictionary" этой же секции, например:
[HybridAttack]
Dictionary=D:\InsidePro (Mini).dic
1=@?d?d?d?d
2=?u?u@
3=admin@

Примеры правил для этой атаки:
@?d?d?d?d – к паролю из словаря будет справа добавлено 4 цифры
?u?u@ – к паролю из словаря будет слева добавлено два символа из диапазона "A...Z"
admin@ – к паролю из словаря будет слева добавлено слово "admin"

В этой атаке поддерживаются и сложные маски типа ?u@?l?l, ilove@?d?d?d?d или Summer?u?d@?s (т.е. можно задавать маски как слева, так и справа от пароля из словаря). Более того – программа поддерживает маски любой длины, к примеру – @?d?d?d?d?d?d или ?u@?l?l?d?d, но при единственном ограничении – количество комбинаций паролей в одном правиле не должно превышать значения StreamProcessors * StreamProcessors * PasswordsPerThread.

[Settings]

В этой секции задаются общие настройки программы.

AttackMode – этот параметр позволяет выбрать нужную атаку и он может иметь следующие значения: 1 (атака полным перебором), 2 (атака по маске), 3 (атака по словарям) или 4 (гибридная атака). Также в этом параметре через запятую можно указать номер правила, с которого начать атаку, например:
AttackMode=2,4 – начать атаку по маске с 4-й маски
AttackMode=3,10 – начать словарную атаку с 10-го словаря
AttackMode=4,64 – начать гибридную атаку с 64-го правила

LastPassword – в этом параметре сохраняется последний обработанный пароль. Соответственно, при последующем запуске программы атака будет продолжена именно с этого пароля, поэтому для того, чтобы начать атаку сначала, необходимо очистить значение данного параметра. Примечание: если вы не хотите, чтобы в INI-файле сохранялся последний обработанный пароль, то установите на этот файл атрибут "Read-only" (только для чтения).

CurrentDevice – этот параметр позволяет выбирать, на каком из доступных GPU запускать атаку. Это позволяет более эффективно управлять нагрузкой на видеокарту, а также дает возможность одновременно запускать на разных GPU атаки с разными настройками. Значение по умолчанию – 1. Для одновременного использования нескольких GPU нужно через запятую перечислить их номера, например:
CurrentDevice=1,2
CurrentDevice=1,4
CurrentDevice=2,3,4
CurrentDevice=1,2,5,6,7,8
В этом режиме для каждого GPU можно задавать свои значения параметров StreamProcessors и PasswordsPerThread, также перечисляя их через запятую, например:
CurrentDevice=1,2
StreamProcessors=112,96
PasswordsPerThread=6000,2000
или
CurrentDevice=1,2,3,4
StreamProcessors=128,128,128,64
PasswordsPerThread=3000,3000,3000,100

StreamProcessors – количество потоковых процессоров в GPU, по умолчанию – 128.

PasswordsPerThread – количество паролей, которое будет обрабатываться в одном потоке, по умолчанию – 3000 паролей для несоленых хэшей и 100 паролей для соленых.

SaltInHexFormat – этот параметр определяет, в каком формате задана соль (или имя пользователя):
"0" (по умолчанию) – в обычном текстовом виде
"1" – в шестнадцатеричном виде

RemoveCrackedHashes – этот параметр позволяет удалять из исходного текстового файла хэши, пароли к которым были найдены во время атаки. При значении "1" хэши удаляются, при значении "0" (по умолчанию) – не удаляются.

OutputFileFormat – этот параметр определяет формат, в котором найденные пароли добавляются в файл результатов EGB.out. Поддерживаются следующие значения:
"0" – в файл ничего не пишется
"1" (по умолчанию) – хэш:пароль
"2" – пароль
"3" – хэш:[color=blue]пароль[/color]
"4" – хэш:соль:пароль

ShowFoundPasswords – этот параметр определяет, показывать найденные пароли на экране или нет. При значении '1' (по умолчанию) пароли показываются, при значении '0' - нет.

CustomCharacterSet1 ... CustomCharacterSetZ – пользовательские наборы символов, которые можно использовать в атаке по маске и в гибридной атаке, обозначая их как наборы символов ?1 ... ?9 и ?A ... ?Z.
FAQ

Q1: Какие системные требования имеет программа?
A: Главное требование, чтобы видеокарта поддерживала технологию CUDA (список таких видеокарт можно найти здесь), а также для нее должны быть установлены самые свежие драйвера. Также необходимо, чтобы видеокарта поддерживала архитектуру sm_11 и выше.

Q2: У меня видеокарта на процессоре фирмы ATI(AMD). Будет ли на ней работать программа?
A: Нет, т.к. технология CUDA (Compute Unified Device Architecture) поддерживается только в видеопроцессорах фирмы NVIDIA.

Q3: Я запускаю программу, появляется консольное окно и тут же оно закрывается. Как мне работать с программой?
A: Для комфортной работы с программой используйте любой файловый менеджер, работающий в консоли – например, FAR Manager.

Q4: При запуске программа выдает ошибку "CUDA Error...". Как ее устранить?
A: Сначала убедитесь, что ваша видеокарта поддерживает технологию CUDA и установлены самые свежие драйвера. Если же эти требования выполнены, но ошибка все равно возникает, то для анализа ситуации пришлите в Службу поддержки текст ошибки и точное наименование вашей видеокарты.

Q5: При запуске программы компьютер зависает или возникает "синий экран смерти" (BSOD). Как это исправить?
A: Такая ситуация может возникнуть, если видеокарта разогнана, поэтому рекомендуется вернуть частоты памяти и ядра в первоначальные значения. Также убедитесь, что ваша видеокарта надежно и качественно охлаждается, т.к. программа задействует видеопроцессор на полную мощность – соответственно, при таком режиме работы его температура повышается. Также при полной загрузке видеокарта начинает потреблять много энергии и ваш блок питания может не "потянуть" такую нагрузку.

Q6: Я запустил программу, как мне прервать ее работу?
A: Достаточно нажать комбинацию клавиш Ctrl+C или Ctrl+Break.

Q7: Я запустил программу и теперь мой компьютер сильно тормозит. Как это исправить?
A: По умолчанию программа настроена на экстремальный режим работы, в котором компьютер выполняет только одну задачу – восстановление паролей с максимально возможной скоростью. Разумеется, это приводит к тому, что скорость работы остальных программ существенно замедляется и для снижения нагрузки на компьютер необходимо уменьшить значение параметра PasswordsPerThread в INI-файле.

Q8: Восстанавливает ли программа пароли, содержащие национальные символы – например, русские?
A: Да, для этого в параметре CharacterSet вашего INI-файла введите нужный набор символов в кодировке Windows.

Q9: Когда я запускаю атаку на соленые хэши, мой компьютер зависает или показывает BSOD. Почему?
A: Т.к. скорость работы с солеными хэшами уменьшается пропорционально их количеству, то при большом числе хэшей нужно обязательно уменьшать значение параметра PasswordsPerThread (а при необходимости – и StreamProcessors). Иначе общее количество потоков в GPU, умноженное на количество обрабатываемых паролей в каждом потоке, при маленькой скорости атаки приведет к тому, что GPU будет перегружен вычислениями и перестанет отвечать на запросы драйвера.

Q10: А как мне определить – перегружен GPU или нет?
A: В нормальном режиме EGB обновляет на экране скорость атаки 2 раза в секунду, поэтому если у вас на экране скорость обновляется заметно реже, то ваш GPU перегружен и нужно снижать значение параметров PasswordsPerThread и StreamProcessors.

Q11: Когда я запускаю атаку с длинной маской, то строка состояния (показывающая скорость атаки и текущий пароль) иногда не вмещается в размер консольного окна. Как это исправить?
A: Чтобы длинные пароли корректно отображались в строке состояния программы, необходимо увеличить ширину консольного окна через его свойства (эта возможность доступна, начиная с Windows 2000/XP) – например, вместо стандартных 80 символов можно сделать 100 или даже еще больше (если позволяет разрешение экрана и текущий шрифт консольного окна).

Q12: Планируется ли ввести в программу поддержку OpenCL?
A: В ближайшем будущем - вряд ли, но в дальнейшем вполне возможно.

Q13: Через некоторое время после начала работы программы иногда выдается ошибка "CUDA Error...". В чем может быть причина?
A: Чаще всего это связано с тем, что видеокарта продолжает активно использоваться - запускается скринсэйвер, проигрывается видео и т.д. Очевидно, что для стабильной многочасовой (и даже многодневной) работы EGB необходимо исключить запуск таких посторонних программ во время ее работы.

Copyright © 2008-2014 InsidePro Software