Einleitung

Navigation: »Keine übergeordneten Themen verfügbar«

Einleitung

HeavyLoad simuliert eine starke Belastung auf einem PC und erlaubt Ihnen zu überprüfen, ob Workstation und Server PCs auch unter starker Belastung zuverlässig arbeiten.

Außerdem ermöglicht es HeavyLoad das Verhalten von Systemen unter schwindenden System-Ressourcen (Arbeitsspeicher, freier Speicherplatz) zu testen.


Installation

Installation

Führen Sie das Installationsprogramm aus und folgen Sie den Anweisungen. HeavyLoad kann über die Systemsteuerung wieder deinstalliert werden. Unterstützte Betriebssysteme sind Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7, inklusive der 64Bit Versionen. Neben einem normalen Installer wird auch eine ZIP-Datei mit HeavyLoad zur Verfügung gestellt.

Oder installieren Sie HeavyLoad als portable Version auf einem USB-Stick. Hierzu wählen Sie während der Installation ein Verzeichnis auf Ihrem USB-Stick aus und aktivieren im folgenden Dialog unter Zusatzfunktionen "Als portable Version installieren".


Schnellstart

Schnellstart

Nach der Installation kann HeavyLoad über das Windows Start-Menü oder der Verknüpfung auf dem Desktop gestartet werden. Im Folgenden erklären wir die wichtigsten Elemente des Hauptfensters:

1.Die Gewünschten Test Methode(n) auswählen.

2.In den Optionen können erweiterte Einstellungen wie Grenzwerte, Laufzeit und Anzahl der benutzten Prozessorkerne eingestellt werden.

3.Über diese Schaltfläche wird der Testdurchlauf mit den zuvor gewählten Testmethoden gestartet.

4.Über diese Schaltfläche werden die Tests beendet.

5.Hier kann der Aktualisierungsintervall des Diagramms eingestellt werden, auch werden hier die darzustellenden Werte ausgewählt.

6.Die Statusleiste zeigt Hinweistexte und informiert über relevante Werte während des Tests.


Start-Parameter

Navigation: Schnellstart >

Start-Parameter

HeavyLoad kann mit folgenden Parametern über ein Skript oder die Kommandozeile aufgerufen werden.

/CPU <n>

Aktiviert die Test Methode: Prozessor auslasten.

Durch n kann optional die Anzahl der zu belastenden Prozessorkerne eingestellt werden.Der maximale Wert ist hierbei vom System abhängig.

/MEMORY <n>

Aktiviert die Test Methode: Arbeitsspeicher reservieren.

Optional kann mit n der frei zu bleibende Arbeitsspeicher in MB angegeben werden.

/FILE <n>

Aktiviert die Test Methode: Testdatei erzeugen. Optional kann mit n der frei zu bleibende Festplattenplatz angegeben werden.

/TESTFILEPATH <"\path">

Gibt den Pfad an, an welchem die Testdatei gespeichert werden soll. Dieser Parameter kann nur in Verbindung mit dem Parameter /FILE verwendet werden.

/TREESIZE

Aktiviert die Test Methode: TreeSize ausführen.

/GPU

Aktiviert die Test Methode: GPU auslasten.

/DURATION <n>

Legt die Laufzeit in n Minuten fest. Wird dieser Parameter nicht gesetzt, läuft der Test dauerhaft. Die Angabe von n ist bei diesem Parameter Pflicht!

/AUTOEXIT

Beendet das Programm nach der unter /DURATION mit n angegebenen Laufzeit automatisch. Dieser Parameter kann nur in Verbindung mit dem /DURATION n Parameter verwendet werden.

/START

Startet den Testdurchlauf.

Beispiel:

HeavyLoad.exe /CPU 2 /MEMORY 200 /FILE 150 /TESTFILEPATH "C:\Users\exampleuser\AppData\Local\Temp\" /GPU /TREESIZE /DURATION 10 /AUTOEXIT /START


Was ist neu?

Was ist neu?

Änderungen in V3.4: (22. August 2016)

·Bitte beachten Sie: Die Unterstützung von Windows XP und Server 2003 wurde mit dieser Version eingestellt.

·Bugfix: Die Testmethode "GPU Auslasten" konnte mit aktuellen OpenGL Treibern keine Texturen laden, um die Auslastung zu erzeugen. Die zur Erzeugung der Texturen verwendete Komponente wurde aktualisiert.

·Bugfix: Seit Windows 10 konnten einzelne CPU-Kerne nicht mehr separat ausgelastet werden. Dieser Fehler wurde behoben. Die Belastungs-Threads werden nun explizit den jeweiligen CPU-Kernen zugeordnet.

·Bugfix: HeavyLoad verursachte zur Ermittlung des freien Speicherplatzes (StatusBar) eine hohe CPU-Last, auch wenn kein Test gestartet wurde. Diese Grundlast konnte auf < 5% reduziert werden.

·Der Test "Festplattenzugriffe Simulieren" verwendet nun die neueste Version von TreeSize Free (V3.4.5).

·Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V3.3.1: (15. April 2014)

·Der Test "Festplattenzugriffe Simulieren" verwendet nun die neueste Version von TreeSize Free (V3.0.1).

·Bugfix: Ein Fehler beim Starten von HeavyLoad über Kommandozeile mit GPU-Stresstest wurde behoben.

·Bugfix: Ein Darstellungsfehler der Shortcuts im Optionendialog, der bei Verwendung des Windows Basis-Designs "Windows Klassisch" auftrat, wurde behoben.

·Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V3.3: (26. November 2013)

·Die Testmethode "Arbeitsspeicher Reservieren" wurde überarbeitet. HeavyLoad ist nun in der Lage, den eingestellten Grenzwert stabiler zu halten.

·HeavyLoad ist nun auch als native 64-Bit-Version erhältlich. Hierdurch lässt sich nun Arbeitsspeicher größer als 2 GB effektiver auslasten.

·Verbesserung der Bedienbarkeit: Der Optionendialog ist nun auch über Shortcuts steuerbar.

·Portable Version: Die versehentliche Verwendung eines nicht existierenden Pfades zum Speichern der Testdatei wurde unterbunden.

·Der Test "Festplattenzugriffe Simulieren" verwendet nun die neueste Version von TreeSize Free (V2.7).

·Bugfix (portable Version): Der Fehler beim Umstieg auf ein System mit weniger CPU-Kernen wurde behoben.

·Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V3.2: (Oktober 2012)

·Im Optionendialog können unter "Verschiedenes" nun die aktuellen Einstellungen von HeavyLoad als Kommandozeilenparameter in die Zwischenablage kopiert werden.

·Ein neuer Kommandozeilenparameter /AUTOEXIT wurde eingeführt. Es ist nun möglich, das Programm automatisch beenden zu lassen, wenn die durch den Parameter /DURATION angegebene Laufzeit n abgelaufen ist.

·Mit dem Kommandozeilenparameter /CPU (n) kann nun optional die Anzahl der zu belastenden CPU Kerne beim Test "CPU Auslasten" eingestellt werden.

·Mit dem Kommandozeilenparameter /MEMORY (n) kann nun optional der beim Test "Arbeitsspeicher reservieren" frei zu bleibende Arbeitsspeicher in MB eingestellt werden.

·Mit dem Kommandozeilenparameter /FILE (n) kann nun optional der beim Test "Testdatei erzeugen" freizubleibende Festplattenplatz in MB eingestellt werden.

·Ein neuer Kommandozeilenparameter /TESTFILEPATH ("\path") wurde eingeführt. Hiermit kann der Pfad, an dem die temporäre Testdatei erstellt werden soll, angegeben werden.

·Der 3D-Würfel des GPU-Stresstestes skaliert nun mit der Fenstergröße.

·Die Updatefunktion leitet nun auf die HeavyLoad Download-Seite weiter wenn eine neue Version verfügbar ist.

·Bugfix: Die HeavyLoad Benutzeroberfläche friert nicht mehr ein, wenn das Programm mit den Kommandozeilenparametern "/CPU /GPU" gestartet wird.

·Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V3.1: (Mai 2012)

·HeavyLoad kann nun auch den Prozessor der Grafikkarte belasten.

·Die Bilder pro Sekunde werden beim Grafik-Prozessor Belastungstest gemessen und angezeigt.

·HeavyLoad kann nun auch als portable Version installiert werden, z.B. auf einem USB-Stick. Die Einstellungen werden dann im Pfad der Anwendung gespeichert.

·Verbesserte Unterstützung für Multicore-Prozessoren.

·Die Anzahl der zu belastenden CPU-Kerne kann nun eingestellt werden.

·Die Priorität, mit der die Tests laufen, kann nun eingestellt werden.

·Der Speicherort der temporären Test-Datei kann jetzt frei gewählt werden.

·Die Test-Datei wird bei Erreichen des Grenzwertes so lange überschrieben, bis mehr Festplattenplatz frei geworden ist.

·Die Hilfedatei kann nun auch aus den Optionen heraus geöffnet werden und zeigt sofort die zu der Funktion passende Seite an.

·Der Optionendialog wurde komplett überarbeitet.

·Die Benutzeroberfläche wurde überarbeitet.

·Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V3.0: (November 2010)

·Die Benutzeroberfläche wurde überarbeitet.

·HeavyLoad ist jetzt in einer deutschen Version verfügbar.

·HeavyLoad kann jetzt mit Kommandozeilen-Parametern aufgerufen werden.

·HeavyLoad ist jetzt in der Lage, auf Systemen mit mehr als 2GB Arbeitsspeicher den kompletten Arbeitsspeicher zu reservieren.

·Im Graphen wird jetzt zusätzlich der freie Speicherplatz der Systempartition angezeigt.

·Die Dauer des Tests kann im Optionen-Dialog festgelegt werden.

·Die Restkapazität von Festplatte und Arbeitsspeicher kann jetzt frei definiert werden.

·Es besteht nun die Möglichkeit, die Geschwindigkeit, in der die temporäre Testdatei geschrieben und der Arbeitsspeicher reserviert wird, zu bestimmen.

·HeavyLoad bietet jetzt die Möglichkeit, über die Anwendung nach verfügbaren Updates zu suchen.

·HeavyLoad speichert jetzt seine Einstellungen in einer XML-Datei im Profil des Benutzers.

·Die Unterstützung für Windows 2000 wurde beendet, da Microsoft seinerseits die Unterstützung hierfür im Juli 2010 eingestellt hat.

·Bugfix: Die temporäre Testdatei kann nun in allen Situationen gelöscht werden.

·Bugfix: Die temporäre Testdatei kann nun auch wenn die "Arbeitsspeicher reservieren" Test Methode aktiv ist, fortlaufend geschrieben werden.

·Bugfix: Der Graph für den freien Arbeitsspeicher stellt jetzt auch auf Systemen mit mehr als 4GB Arbeitsspeicher den korrekten Wert da.

·Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V2.4.1: (Dezember 2009)

·Unterstützung für Windows 7.

·Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V2.4: (Juni 2008)

·Multicore-Prozessoren werden jetzt voll ausgelastet.

·Unterstützung für Windows Server 2008 wurde hinzugefügt.

·Installer wurde hinzugefügt.

·Ein Fehler, der auftrat, wenn mehrere Instanzen von HeavyLoad gestartet waren, wurde behoben.

·Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V2.3.1: (Januar 2008)

·Hilfe-Funktionalität verbessert.

Änderungen in V2.3: (April 2007)

·Unterstützung für Windows Vista.

·Die verstrichene Testdauer wird jetzt angezeigt.

·Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V2.2: (Januar 2007)

·Fehler unter Windows Vista behoben.

·Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Änderungen in V2.1: (Februar 2006)

·Teststatus, CPU-Belastung und verfügbarer Speicher werden in der Statusleiste angezeigt.

·Programm startet zentriert, Benutzeroberfläche überarbeitet.

Änderungen in V2.0: (Dezember 2002)

·Belastungsgraph wurde hinzugefügt.

·Toolbar und Hilfe Dialog wurden hinzugefügt.

·Es gibt nun die Möglichkeit, Testabläufe individuell zu selektieren.

·Bildschirmschoner und Stromsparmodus werden deaktiviert während HeavyLoad gestartet ist.

Änderungen in V1.0: (Januar 1999)

·Veröffentlichung der ersten Version.


Test Methoden

Test Methoden

TestCPU

Prozessor auslasten

Dieser Test lastet HeavyLoad den Prozessor zu 100% aus. Hierzu wird eine komplexe Berechnung ausgeführt.

TestWriteFile

Testdatei erzeugen

HeavyLoad erzeugt eine Testdatei, die während des Texts kontinuierlich mit Daten beschrieben wird. Die Datenrate, mit der die Testdatei auf die Festplatte geschrieben wird, kann in den Optionen festgelegt werden.

TestMemory

Arbeitsspeicher reservieren

HeavyLoad reserviert kontinuierlich Arbeitsspeicher, was dazu führt, dass dem System weniger Arbeitsspeicher zur Verfügung steht. Die Datenrate, mit der HeavyLoad den Arbeitsspeicher reserviert, kann in den Optionen festgelegt werden.

TestTreeSize

TreeSize ausführen

Dieser Test startet für jede lokale Partition eine Instanz von TreeSize Free. TreeSize Free läuft dabei in einer Endlosschleife, bis der Test beendet wird.

TestGPU

GPU auslasten

HeavyLoad belastet den Prozessor der Grafikkarte. Eine 3D-gerenderte Grafik wird verwendet, um die GPU-Nutzung während des Tests zu erhöhen.


Optionen

Optionen

Der Optionen Dialog kann über das Menü Extras > Optionen... oder über die Schaltfläche [image] geöffnet werden. Er enthält folgende Reiter:

· CPU

· Speicher

· Testdatei

· Verschiedenes


CPU Optionen

Navigation: Optionen >

CPU Optionen

Unter dem Reiter "CPU", können "CPU Optionen" und "Thread Optionen" eingestellt werden.

CPU Optionen

Verwendete Prozessorkerne

Wenn das System über einen Prozessor mit mehreren Kernen verfügt, kann hier eingestellt werden, wie viele davon für den CPU-Belastungstest verwendet werden sollen.

Thread Optionen

Thread Priorität

Diese Option erlaubt das Festlegen der Thread Priorität mit der die einzelnen Tests laufen sollen. Sie kann dazu verwendet werden, die Systembelastung durch HeavyLoad präziser zu steuern. Die Aktivierung der Option "Ungenutzte CPU-Zeit" führt dazu, dass nur Prozessorzeit genutzt wird, die nicht von anderen Prozessen verwendet wird. Eine höhere Priorität kann dazu führen, dass andere Anwendungen während der Ausführung der Tests nicht mehr oder verzögert reagieren.


Speicher Optionen

Navigation: Optionen >

Speicher Optionen

Unter dem Reiter "Speicher", können der "Grenzwert" und die "Belastung" eingestellt werden.

Grenzwerte

Freier Speicher

Legt den minimal verbleibenden Arbeitsspeicher fest.

Hinweis: Da auch andere Programme Arbeitsspeicher beanspruchen, kann es vorkommen, dass nachdem HeavyLoad den Grenzwert erreicht hat, der freie Arbeitsspeicher unter den eingestellten Wert fällt.

Belastung

Schreibgeschwindigkeit Arbeitsspeicher

Legt die Geschwindigkeit in MB/s fest, mit der HeavyLoad Arbeitsspeicher reserviert.

Hinweis: Der maximale Wert ist hierbei vom System abhängig.


Testdatei Optionen

Navigation: Optionen >

Testdatei Optionen

Unter dem Reiter "Testdatei" kann der "Grenzwert", die "Belastung" und der "Speicherort der Testdatei" eingestellt werden.

Grenzwerte

Freier Speicher

Legt den minimal zu verbleibenden freien Festplattenspeicherplatz auf der Systempartition fest.

Hinweis: Da auch andere Programme Festplattenspeicher beanspruchen, kann es vorkommen, dass nachdem HeavyLoad den Grenzwert

erreicht hat, der freie Festplattenspeicher unter den eingestellten Wert fällt.

Belastung

Schreibgeschwindigkeit Testdatei

Legt die Geschwindigkeit in MB/s fest, mit der HeavyLoad auf die Festplatte schreibt.

Hinweis: Der maximale Wert ist hierbei vom System abhängig.

Speicherort der Testdatei

Hier kann der Speicherort, an dem die Testdatei temporär abgespeichert wird, festgelegt werden.


Verschiedenes Optionen

Navigation: Optionen >

Verschiedenes Optionen

Unter dem Reiter "Verschiedenes" können die Laufzeit und die Programmeinstellungen geändert werden.

Laufzeit

Dauerhaft

Der Testdurchlauf läuft solange, bis er manuell beendet wird.

Test beenden nach [Wert]

Der Testdurchlauf wird nach der voreingestellten Dauer automatisch beendet.

Automatisch beenden

HeavyLoad automatisch beenden nachdem die angegebene Dauer unter "Test beenden nach" abgelaufen ist.

Programmeinstellungen

Zurücksetzen aller Programmeinstellungen auf ihre Initialwerte.

Kommandozeile

Erzeugen der Kommandozeilenparameter, mit den aktuell verwendeten Einstellungen. Der erzeugte String wird in die Zwischenablage kopiert und kann anschließend mit [STRG+V] in CMD.EXE oder in einem Skript verwendet werden um HeavyLoad per Kommandozeilenaufruf zu starten.


Hinweise & Anregungen

Hinweise & Anregungen

·HeavyLoad verwendet unsere Freeware TreeSize Free in einer Endlosschleife, um mehr Festplattenaktivität zu produzieren. Mehr Informationen über TreeSize finden Sie unter http://www.jam-software.de/treesize_free.

·Nach einer längeren Verwendung von HeavyLoad, kann es vorkommen, dass der Arbeitsspeicher fragmentiert und die Auslagerungsdatei sehr stark angewachsen ist. Sie sollten daher Windows neu starten, nachdem Sie HeavyLoad verwendet haben.

·Wenn HeavyLoad nicht unter normalen Bedingungen geschlossen wurde, z.B. bedingt durch eine instabile Hardware oder einen Betriebssystem-Fehler, kann die während des Tests angelegte Test-Datei in Ihrem Temp-Ordner zurückbleiben. Diese muss von Hand gelöscht werden.

·Der GPU-Belastungstest arbeitet nur zuverlässig, wenn eine eigenständige Grafikkarte mit aktuellen Treibern installiert ist. Ohne eigenständige Grafikkarte kann dieser Test unter Umständen eine sehr hohe CPU-Auslastung zur Folge haben oder scheitern. Ebenso kann das Ausführen auf virtuellen Maschinen oder über Remote-Desktop zu einer fehlerhaften Darstellung der 3D-Komponente führen.


Copyright & Kontakt

Copyright & Kontakt

Copyright © 2016 Joachim Marder e.K.

JAM Software GmbH
Am Wissenschaftspark 26
54296 Trier

FAX: | 0651-145653-29
WWW: | http://www.jam-software.de
Support: | http://www.jam-software.de/customers/contact.php
E-Mail: | HeavyLoad@jam-software.de
Handelsregister: | HRB: 4920 beim Amtsgericht Wittlich
Umsatzsteuer ID: | DE234825349
Geschäftsführer: | Joachim Marder

Klicken Sie hier um die Lizenzbedingungen von Drittanbieter-Komponenten einzusehen.


Drittanbieter Lizenzbedingungen

Drittanbieter Lizenzbedingungen

Dieses Programm benutzt Komponenten von www.glscene.org.